VW Golf R32 Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hi, I have just bought my 2nd dbp mk5 R32 dsg, after having to sell my old one.

I have a very unexpected issue with my new one, ESP!!!

My old one was a 58 2009, when I switched ESP off it totally switched it off. My new one is 58 2008 and to my surprise when I try to drift it a little the ESP cuts in. The old one would not do this.

Is there a fix for this does anyone know?

Cheers
 

·
Senior Member
Joined
·
19,449 Posts
That's odd.

As far as I'm aware the ESP cannot be switched off fully on the MK5 R32 and infact any VW of that era.

VW did update the ESP on their cars from around 2011 to have a 2-stage off process where it could have the "soft" off and still cut in and fully off, where it won't cut in.

Welcome to the forum.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Hi Bob, cheers for the reply! Nah definitely a difference from the 2008 58 to the 2009 58, unless it had been mapped out or something on my last one, doubt it though as it was box standard aswell.

Never mind, might just save me one day, does spoil it a bit though.

Cheers
 

·
Member
Joined
·
2,204 Posts
Have you got VCDS?

If so, login to the ABS ECU and try this, which disables the ESP completely:-

Original: 23049 = 101101000001001 ABS/ESP/EDL​
-2048 = 100000000000 (ESP Bit)​
New: 21001 = 101001000001001 ABS/EDL (no more ESP)​

To perform it:​
VCDS -> Coding -> 07 Login 40168​
Coding 11 -> Enter 21001 in place of 23049 and "Do it" button​

The only thing is you need to change it back to 23049 if you want the ESP button to work again. It might work, might not as there are subtle differences between the ABS controllers.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top