VW Golf R32 Forum banner
1 - 20 of 20 Posts

·
Registered
Joined
·
200 Posts
Discussion Starter · #1 ·
Flashing Blocked PRNDS of Death. DSG owner's worst nightmare!

About 2 weeks ago I got in the MK5 R32, started it and it wouldn't shift into gear. I looked down at the display and I had the flashing PRNDS of death... Felt sick to the pit of my stomach. I turned off the ignition, turned it on again and it started fine. Drove home no further issues until...

Fast forward to this morning and I am driving to work; about half a mile from my house in 6th gear, going up a slight gradient hill at 30 mph and the engine all of a sudden starts to rev high. I glance at the display panel and the flashing blocked PRNDS is there and the car had dropped into neutral I hit the brake as the green brake symbol is showing and it goes back into gear and drives fine all the way for the next couple of miles to work.

So it looks like my mechatronic unit is on it's way out or hopefully a dodgy connection. I've Prepared myself for the worst case scenario. Gonna give my mechanic a call later to see what he reckons.

Anyone got VAGCOM local to Bluewater Kent who can help me with diagnostics please?

ECS tuning for recon units- how good are they?

Need to weigh up my options.

Cheers and FML
 

·
Registered
Joined
·
200 Posts
No none of those symptoms, slight donk sometimes but not clunk when going into first. No jerkiness or kangarooing when going slow.

Had dsg and haldex oil change done at last service.

Usual occasional DSG roundabout thing when it selects wrong gear and makes you look like a tool!
 

·
Member
Joined
·
297 Posts
It colud just be the gear selector. The bit around the gear stick with the leather on and the plastic bit with the gears on that lights up. There is a metal contact around the gear stick that can break or short circuit. It's not common but it does happen. It's about 200 quid to fix.
I have had my mech unit replaced in the past, so I know it's not a bill that is swallowed easily. Best bet get your fault codes scanned to find the fault.
 

·
Registered
Joined
·
1,191 Posts
First of all before you go spending.
Get it on vag com you should be able to re-calibrate the mechatronic unit.
My pal went & replaced whole gearbox & mechatronic unit on a mk6 r.
He sold the so called faulty gearbox to awesome gti, they later told him it wor kw's perfect just needed re-calibrating. Give them a call they should be able to help pal.
 

·
Registered
Joined
·
929 Posts
Krew76 said:
Getting Vag commed this afternoon. Let's see what happens. dde2f
How did you get on? Was it the bad news you was dreading or did you end up having a bit of good luck?

I thought I had problems a while ago with my mechatronics unit but turned out to be just a lose connection on my MAF sensor to my induction kit but all sorted now.

Hope it isn't ya mechatronics mate
 

·
Senior Member
Joined
·
633 Posts
Hi Krew!
I had the PRNDS flashing on my car on the way back home just the day I bough it. I let you imagine how gutted I was...
Fortunately it was just a problem with the gear selector/lever. At VW they changed the whole unit under warranty and since then it working fine.

Hope it will be something as simple as that for you too. Good luck mate!
 
  • Like
Reactions: Krew76

·
Registered
Joined
·
200 Posts
Discussion Starter · #10 ·
Hi

i got it Vag commed and it showed the following code.

28775 - "No communication with gear selector module U0103

Since Friday i haven't seen the "Prnds of death" I've been proper paranoid and can't stop glancing at the dash waiting for something bad to happen. As you can imagine.

Today I've clocked up around 40miles. Since leaving the garage and Close to home it started doing the dodgy can't pull away in first thing. Doesn't want to creep in reverse and clunks as it engages.
 

·
Registered
Joined
·
200 Posts
Discussion Starter · #11 ·
Hi Krew!
I had the PRNDS flashing on my car on the way back home just the day I bough it. I let you imagine how gutted I was...
Fortunately it was just a problem with the gear selector/lever. At VW they changed the whole unit under warranty and since then it working fine.

Hope it will be something as simple as that for you too. Good luck mate!
What other symptoms did you have?
 

·
Senior Member
Joined
·
633 Posts
What other symptoms did you have?
Nothing special... the car drove normal. Just maybe the gear lever a bit harder to move.
 

·
Registered
Joined
·
200 Posts
Discussion Starter · #14 ·
My mechanic said as it hasn't been playing up and it's happened on 2 occasions, just live with it until it gets worse but since leaving there it's got progressively worse and worse showing new symptoms. Gonna book it in and see what vag com says now. What a great start to the week huh?

I took it out just now and it's just the same. Seems to have issues only when in first or reverse. Changes gear fine in D and when shifting manually.
 

·
Senior Member
Joined
·
1,435 Posts
I put up with mine for nearly a year and it would go as long as 2 Months without flashing but the clunking etc was usually present.
On rare days it behaved perfectly but it took the pleasure out of driving the car knowing it was not perfect.
Got new Mechatronics - now brilliant.
My regret was that I waited so long before getting it fixed.

Good luck in getting it sorted.

Feel free to PM if any questions.
 

·
Registered
Joined
·
200 Posts
Discussion Starter · #17 ·
My current ride, gone back to pedal power. Lucky work is a 2mile or so ride and it's sunny today.

 

·
Member
Joined
·
158 Posts
Happened to me very similar, fault code was lost communication with gear selector I pulled up the stick surround and there's a multi plug coming off the lever, pulled it checked it and looked good so wd40 and back together and problem solved, that was a year ago
 
1 - 20 of 20 Posts
Top