VW Golf R32 Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
139 Posts
Morning All,

I appears to have a "knocking" noise coming from my front right suspension area but it only happens under specific conditions. The car must be warm (driven for around 20 minutes) and at a low speed ~5-10mph and every so often a "knocking" noise will occur from the front right wheel/suspension area.

I've recently had the car serviced in which the Drop links and ARB bushings were replaced, nothing wrong with the wheel bearings, brakes or 4WD system. I've taken this to my mechanic who has driven the car while the noise has been present, and he is stumped as to what might be causing this. He has stripped down the whole suspension system for the front right side, tightened and replaced.

I thought this might be worth posting to see some of the experts opinions on what might be causing my problem, any ideas?

All help much appreciated.

Thanks.

Jed
 

·
Registered
Joined
·
139 Posts
Discussion Starter · #3 ·
Could very well be the subframe knocking, I have/had the very same issue, it was resolved buy fitting the 034motorsport subframe locking kit. but not before I spent about a grand changing every other bush/shock/spring/mount on the whole car. Do yourself a favour and check the subframe bolts are not shifting before you spend too much
Thanks, I'll have a look into this
 

·
Registered
Joined
·
420 Posts
Could very well be the subframe knocking, I have/had the very same issue, it was resolved buy fitting the 034motorsport subframe locking kit. but not before I spent about a grand changing every other bush/shock/spring/mount on the whole car. Do yourself a favour and check the subframe bolts are not shifting before you spend too much
Isn't this a Mk5 issue...?? Didn't know mk4's suffered from this.
 

·
Registered
Joined
·
139 Posts
Discussion Starter · #7 ·
Still having this issue unfortunately
, Does anybody have any ideas before I go down the replacing parts route?

Thanks.
 

·
Registered
Joined
·
4,468 Posts
I reckon it's the suspension piston/strut. If it happens after driving for a bit first.
 

·
Registered
Joined
·
139 Posts
Discussion Starter · #9 ·
I reckon it's the suspension piston/strut. If it happens after driving for a bit first.
Hi James,

Yes it seems to take a while before it happens and only "knocks" when driven at low speeds 5-10mph, and it appears to only happen when the wheel rotates to a certain point which leaves me to think that this could be a wheel bearing or drive shafts?

I've found a couple other threads on here that have suggested a few area's to look for, so I will have a look soon and post back


Cheers
 

·
Registered
Joined
·
139 Posts
Discussion Starter · #11 ·
Any joy on this mate?
Sorry only just seen this, been looking at it today and I think I've found the cause, seems to be related to the top mount. Only seems to knock when its put under pressure and I can see physical movement on it, going to be getting that replaced and ill take it from there.

Now I know that mine is related to top mounts i've been able to find loads of information of people having the same issues, have a look round regarding top mount knocking and see if its any use to you.

Cheers
 
1 - 12 of 12 Posts
Top