VW Golf R32 Forum banner
1 - 20 of 31 Posts

·
Registered
Joined
·
1,228 Posts
Discussion Starter · #1 ·
Right ESP light lit up on Thursday and my mechanic who is a Audi master Tech but now works for the RAC dedicated Audi / VW / Skoda response only had time to plug in and check dignostics to which these faults flagged up.



I asked him to change the break pedal switch which he did quick but not able to check out Haldex cables although he said mk1 tt's used to suffer poor connections after bad weather (snow & salt)

He's gonna look at it next thursday but just want to get any info in the meantime to help!
So come on guys come up with some magic
 
G

·
Taken from Ross tech

01312 - Powertrain Data Bus

01312 - Powertrain Data Bus: Faulty
Possible Symptoms
Malfunction Indicator Light (MIL) ON
Possible Causes
Databus Wiring and/or Connector(s) faulty
Possible Solutions
Check Databus Wiring and/or Connector(s)

01316 - ABS Control Module

01316 - ABS Control Module: No Signal/Communication
Possible Causes
Wiring/Connector(s) from/to ABS Control Module faulty
Fault(s) stored in ABS Control Module
Possible Solutions
Check Wiring/Connector(s) from/to ABS Control Module
Check Measuring Value Blocks (MVB)
Usually Measuring Value Blocks (MVB) 125+ show the current Communication Status

01314 - Engine Control Module

01314 - Engine Control Module: No Communications
Possible Causes
CAN-Databus Wiring/Connectors from/to Engine Control Module faulty
Fault(s) stored in Engine Control Module
Engine Control Module recently flashed or re-mapped
Possible Solutions
Check CAN-Databus Wiring/Connectors from/to Engine Control Module
Check Measuring Value Blocks (MVB)
Usually Measuring Value Blocks (MVB) 125+ show the current Communication Status

01314 - Engine Control Module: Check DTC Memory
Possible Causes
Fault(s) stored in Engine Control Module
Possible Solutions
Check Engine Control Module for Fault Codes
Special Notes
Engine Control Module stored a Code which influences other Control Modules Functionality.
To clear this Fault Code you will need to correct the Problem in the Engine Control Module first.
 

·
Registered
Joined
·
1,228 Posts
Discussion Starter · #3 ·
Thanks for that info! so the last bit, Engine Control Module stored a Code which influences other Control Modules Functionality.
To clear this Fault Code you will need to correct the Problem in the Engine Control Module first.
Could that be causing the ESP fault light?
 

·
Administrator
Joined
·
13,972 Posts
Ime betting its the MAF that is throwing these codes up

Sent from my iPhone 9 in a Time Machine
 

·
Registered
Joined
·
1,228 Posts
Discussion Starter · #5 ·
Ime betting its the MAF that is throwing these codes up

Sent from my iPhone 9 in a Time Machine
Have you had similar experiences then?
 

·
Senior Member
Joined
·
1,935 Posts
That fact you have lost comms with most of your modules says its either the wiring or the CAN gateway screwed up possibly.

How would the MAF influence all these modules? If that was the case just unplug the MAF, clear the faults and see if they come back.
 

·
Registered
Joined
·
1,228 Posts
Discussion Starter · #7 ·
Can a MAF cause these sort of problems?
 

·
Administrator
Joined
·
13,972 Posts
MIQ said:
Yes

Sent from my iPhone 9 in a Time Machine
When mine broke, the vag com said , abs, haldex, AWD, traction control problem

It's because the MAF is not putting the correct mix in it makes all the other sensors go mad , I have a thread somewhere on it

Sent from my iPhone 9 in a Time Machine
 

·
Registered
Joined
·
1,228 Posts
Discussion Starter · #11 ·
When mine broke, the vag com said , abs, haldex, AWD, traction control problem

It's because the MAF is not putting the correct mix in it makes all the other sensors go mad , I have a thread somewhere on it

Sent from my iPhone 9 in a Time Machine
Would your thread still have a link in your content?
 

·
Administrator
Joined
·
13,972 Posts
I have just put the thread to the top of the page

It's called Car Still at Garage

Sent from my iPhone 9 in a Time Machine
 

·
Registered
Joined
·
1,228 Posts
Discussion Starter · #13 ·
Apparently the comms to the haldex is trying to talk to it but it doesn't respond all the time? Does this still sound like a MAF?
 

·
Administrator
Joined
·
13,972 Posts
FLORIDA747 said:
Apparently the comms to the haldex is trying to talk to it but it doesn't respond all the time? Does this still sound like a MAF?
Possibly as it will all switch off to keep it in safe mode .

Has the traction control and abs switched off

Sent from my iPhone 9 in a Time Machine
 

·
Registered
Joined
·
1,228 Posts
Discussion Starter · #15 ·
Possibly as it will all switch off to keep it in safe mode .

Has the traction control and abs switched off

Sent from my iPhone 9 in a Time Machine
If you mean from the switch on the dash that now does nothing, but if i give it some beans it wont spin the fronts which suggest the 4 wheel drive is working.
Also today i felt a clonk from the rear but don't know if i had gone over a stone or something.
 

·
Administrator
Joined
·
13,972 Posts
FLORIDA747 said:
If you mean from the switch on the dash that now does nothing, but if i give it some beans it wont spin the fronts which suggest the 4 wheel drive is working.
Also today i felt a clonk from the rear but don't know if i had gone over a stone or something.
I meant you can't use the ESP button at the moment and the car drives like an old school one with no assistsance for braking and traction, but the 4 we works, then it's the MAF

Sent from my iPhone 9 in a Time Machine
 

·
Registered
Joined
·
1,228 Posts
Discussion Starter · #17 ·
My mechanic checked all cable underneath today and all seems fine! Also unplugged MAF and still no change? Is it just a case of unplugging it or is there something else you have to do?
Sometimes you can here a ticking from rear diff when stationary but When he tries to go in to diagnostics it stops but won't let him see all data?

Sent from my iPad using Tapatalk HD
 

·
Registered
Joined
·
1,228 Posts
Discussion Starter · #18 ·
I meant you can't use the ESP button at the moment and the car drives like an old school one with no assistsance for braking and traction, but the 4 we works, then it's the MAF

Sent from my iPhone 9 in a Time Machine
Were you able to communicate with comms?
 

·
Registered
Joined
·
1,228 Posts
Discussion Starter · #19 ·
Fitted another Haldex ecu today and all is good again.
 
1 - 20 of 31 Posts
Top