VW Golf R32 Forum banner
1 - 11 of 11 Posts

·
Member
Joined
·
86 Posts
Discussion Starter · #1 ·
hi new to the site, and need some info on the maf sensor, does anyone know what the grams per second should be on idle and wide open throttle, it has felt like it hasnt got the power it used to
 

·
Premium Member
Joined
·
4,542 Posts
Wait for wayne to post up, he just replaced his maf.

I'm not sure of the tech spec for it tho. If its feeling sluggish chances are thats the problem.

How is the air filter looking ? may benefit from a clean.

Also try unplugging the maf and going for a drive, if it pulls better then the mafs knackered. I dont recommend you drive with the maf unplugged other than to test it a short distance.
 

·
Member
Joined
·
86 Posts
Discussion Starter · #3 ·
well ive now replaced the maf for a new unit also replaced the filter for a new one, took it for a spin and feels better but still not right. im maxing at 188g/s :mad: about 6 months ago i was reading 220 g/s ish.:D

i did replace the maf about a month ago for one that gsf supplyed. took it for a spin then and power was all over the place lots of flat spots but again vag com was reading 210/220 g/s took that one back and had my old one back due to the huge flat spots (later found it was the wrong maf (1.8T maf)):011:
 

·
Premium Member
Joined
·
4,542 Posts
could be a coil pack then but i'm sure you'd have had some sort of lumpy running.

Have you done a full vag-com scan ?
 

·
Member
Joined
·
86 Posts
Discussion Starter · #9 ·
could anyone tell me wot ther mafe reads on idle and wide open throttle please cuz it mite just be me
 

·
Member
Joined
·
86 Posts
Discussion Starter · #11 ·
ive mesured it with vag com mate. its really bugging me now, cant think of what it could be. going off to mrc if i cant figure it out i think
 
1 - 11 of 11 Posts
Top