VW Golf R32 Forum banner
1 - 7 of 7 Posts

·
Junior Member
Joined
·
12 Posts
Discussion Starter · #1 ·
Right here goes all of a sudden the R has ended up with a big list of problems

1st off EPC light came on and narrowed it down to brake sender thanks to the forum
2nd speedo stopped and fuel gauge is having a dance up and down but I checked the fuse and checked the connections on the gearbox side and cleaned everything but its still broken.
And the major one is the air con/ heater control head unit control box stopped working so I checked the fuse and it had popped so I changed it and the fans were going on/off all the time and the garage said it's the air con fan but when I removed the key from the ignition every light on the clusters were flashing and then I could smell and eventually seen smoke in the engine bay and the garage said its the big black relay which controls the fans so I removed the box and put the fuse back in and turned the ignition back on and the same again happened

Any ideas towards this.
 

·
Member
Joined
·
139 Posts
You need to plug into the OBD port and scan for fault codes before anyone can even guess what's going on.
That would be first on my list of checks.

Sent from my HTC Sensation Z710e using Tapatalk 2
 

·
Cannot reMember
Joined
·
16,142 Posts
As above you can run an electrical check via VCDS

Sounds to me its shorting somewhere, have a poke around with a multimeter?
 

·
Member
Joined
·
2,204 Posts
Which model of R32? The fan controller sits under the battery in the MK4, so hard to see if smoke comes from that directly but your issues do tally up with a busted fan controller though. Engine and A/C sensors connect to it, so if it develops and internal fault, the fans, clocks and AC panel could all do weird things.

I think the fan controller is stupid money from VW. £400+ from some posts I've read on here?
 

·
Junior Member
Joined
·
12 Posts
Discussion Starter · #7 ·
Quick update the smoke was coming from the oil level sensor on the sump it was cremated so I cut the cable and taped up till I can get a new plug and oil level sensor. I put a fuse back into the number 5 slot in the fuse board again and the fans didn't go off like last time so I thought great and removed the key from the ignition and then all the lights on the clusters went crazy flashing away.

It's a MK4 2003 R by the way
 
1 - 7 of 7 Posts
Top