VW Golf R32 Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi all.
Inherited a mk5, After 2 weeks mil has come on. Vcds indicates both cats below min efficiency and (triggered mil) but also post cat sensor signals swapped.

Although prob too simple to be the case, can anyone confirm where connectors are for the post cat O2 sensors so I can swap over and at least eliminate that possibility.

If anyone can think of other potential solutions be most grateful to receive them. I am concerned that car runs as well as poss and passes not.

Further info: car has Scorpion downpipes and 200 cell cats, custom post cat pipe and mapped by nvm.

Collected it 2 wks ago and drove it home 100 miles on 95ron. Mil did not come on until had filled with 99.

Codes were present on purchase but not triggering mil.

Cheers in advance.

Si
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Hi Chris

Apologies for abbreviation.

Mil - malfunction indicator light - it's the engine management lamp (EML) that is constantly illuminated.

3 codes relating to the EML trigger:

001056 - catalyst system bank 1 - mil
P0420- 001- efficiency below threshold

001072 - catalyst system bank2- mil
P0430 - 001- efficiency Below threshold

000065- oxygen (lambda) sensor signals swapped
P0041 -008 -b1-s2/b2-s2

My thinking is first step is to switch the post cat connectors bank 1-sensor 2 and B2 s2. Although I think unlikely to be solution but certainly worth a try. I can find the pre- cat connectors for s1s banks 1 & 2 top rear right of engine bay on firewall. But not the connectors for post cat sensors.

Cheers

Si
 

·
Registered
Joined
·
79 Posts
I've just had EML come on, fault P0420. Googled it, and everyone seems to recommend cleaning the catalyst. Tried Wynn's Catalyst Cleaner, £9.99 at Halfords and it has worked so far. Give it a go, I know you have not got this fault but it will clean the sensors.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
Cheers pal - funnily enough I've just sent an email to nvm who mapped it to ask for a suggested brand of cat cleaner - Wynn's being my choice
 

·
Registered
Joined
·
2 Posts
Hello everyone, I ordered two oxygen sensors for sensor 1 bank 1 and bank 2, one of these probes has a brown jack input, bosch sent me both with black jacks and they told me they were for bank 1 and bank 2, do you is there a mistake or does it matter that it is not one with a brown jack?
 

·
Registered
Joined
·
420 Posts
If these replacement sensors are post cat, then I think you will find the connectors underneath the floor plastic shields. If you replace one sensor at a time, you cannot cross over the sensor on bank one to the connector for bank two, and vice versa. . When I replaced my pre cat sensors , the new ones both had black connectors , ( but with different length leads ) even though the female receptor plugs were brown and black respectively . No problem as long as the banks are not inadvertently swapped,
 
1 - 7 of 7 Posts
Top