VW Golf R32 Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Hi everyone, I have a strange issue with my Mk4. It kind of has a dead spot/turbo lag with my gearbox even though I am NA. What happens when I put my foot down at around 3000rpm in 3, 4, 5 and 6, the revs goes up slightly up then drop back down. Any idea why this has just started happening?

For context, my golf is on 130k, mapped with highlift cams, which was done three years ago. Only thing that has changed engine wise recently is that I have changed my MAF sensor
 

·
Registered
R32 Mk5 DSG 5 Door
Joined
·
210 Posts
Try the old fashioned way to tell if your clutch is on the way out. Try pulling away in 3rd. If stall the clutch is OK if not you will hear the engine rev higher.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #7 ·
It didn't do it straight away when I put the new MAF in. Could it be something to do with the map I had and fitting a new MAF? The map was done in 2019 at R-tech and maybe it's thrown it off with a new MAF
 

·
Member
Joined
·
330 Posts
Could it be related to the intake changeover valve in the manifold? I think it works/opens at 4k revs but on a mapped car that may be different? I think it's pretty easy to check, you can see it operate.
 

·
Registered
Joined
·
371 Posts
It didn't do it straight away when I put the new MAF in. Could it be something to do with the map I had and fitting a new MAF? The map was done in 2019 at R-tech and maybe it's thrown it off with a new MAF
Won’t have anything to do with the mapping as if r-tech done it then it will be done right
 

·
Registered
Joined
·
270 Posts
Do the revs go up faster than the car is accelerating, then catches back up again, in a manual? That's a clutch.

Or do you mean the car accelerates and then hesitates and loses power and then pulls again, but the engine revs to speed ratio doesn't change?
 
1 - 10 of 10 Posts
Top